Tomorrow's Financial Services - Emergecy Maintenance – Incident details

All systems operational

Emergecy Maintenance

Resolved
Operational
Started almost 4 years agoLasted 13 minutes

Affected

Exchange

Operational from 11:45 AM to 11:57 AM

Exchange OWA

Operational from 11:45 AM to 11:57 AM

Exchange Activesync

Operational from 11:45 AM to 11:57 AM

Updates
  • Resolved
    Resolved

    We just resolved the issue and are monitoring closely for the next few hours.

  • Identified
    Identified

    Clustering services have gone offline and we are checking as to the cause of this situation.

  • Investigating
    Investigating

    We are currently investigating this incident.