Tomorrow's Financial Services - Office 365 Degredation of Exchange Online – Incident details

All systems operational

Office 365 Degredation of Exchange Online

Resolved
Degraded performance
Started over 3 years agoLasted 1 day

Affected

Exchange

Degraded performance from 11:23 AM to 11:39 AM

Exchange OWA

Degraded performance from 11:23 AM to 11:39 AM

Exchange Activesync

Degraded performance from 11:23 AM to 11:39 AM

Updates
  • Resolved
    Resolved

    We just resolved the issue!

  • Monitoring
    Monitoring

    We are watching Microsoft closely for any resolve and to determine when operations will return to normal.

  • Investigating
    Investigating

    Some users may be unable to access their Exchange Online mailboxes via any connection method EX394347 - Last updated: June 21, 2022 6:56 AM