Tomorrow's Financial Services - Exchange Server Restart – Incident details

All systems operational

Exchange Server Restart

Resolved
Under maintenance
Started over 4 years agoLasted 4 minutes

Affected

Exchange

Under maintenance from 10:25 AM to 10:29 AM

Exchange OWA

Under maintenance from 10:25 AM to 10:29 AM

Exchange Activesync

Under maintenance from 10:25 AM to 10:29 AM

Updates
  • Resolved
    Resolved

    All Exchange services have been restored.

  • Investigating
    Investigating

    Due to a failed virtual machine snapshot, we are restarting all Exchange servers. Expected downtime will be only 10-15 minutes.